企业目录:股票入门基础知识 » 资讯 » 通达信公式 » 文章详细

通达信AI资金趋势副图指标

来源:通达信AI资金趋势副图指标 浏览:447次 时间:2019-12-02
通达信AI资金趋势副图指标}
A:=VOL*CLOSE;
 B:=SUM(A,1)/SUM(VOL,1);
 B1:=EMA(B,17);
资金:=(B-B1)*100/B;
 DIFF : EMA(资金,12) - EMA(资金,26);
 DEA : EMA(DIFF,9);
 MACD : 2*(DIFF-DEA), COLORSTICK;
 STICKLINE(MACD>=0,MACD,0,4,1),COLORF00FF0;
 STICKLINE(MACD<0,MACD,0,3.1,1),COLORWHITE;
 STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,3,0 ),COLOR00AAFF;
 STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2.2,0 ),COLOR00BBFF;
 STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,1.8,0 ),COLOR00CCFF;
 STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,1.3,0 ),COLOR00DDFF;
 STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0.9,0 ),COLOR00EEFF;
 STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0.5,0 ),COLOR00FFFF;
 STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,4 ,0 ),COLOR0000AA;
 STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,3.3 ,0 ),COLOR0011BB;
 STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2.2,0 ),COLOR0022CC;
 STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1.65 ,0 ),COLOR0033DD;
 STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1.1 ,0 ),COLOR0044EE;
 STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,0.55 ,0 ),COLOR0055FF;
 STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,4,0 ),COLORAA00BB;
 STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,3.3 ,0 ),COLORBB11BB;
 STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2.2,0 ),COLORCC22BB;
 STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1.65,0 ),COLORDD33BB;
 STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1.1,0 ),COLOREE44BB;
 STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,0.55 ,0 ),COLORFF55BB;
 STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,4,0 ),COLORFFAA00;
 STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,3.3 ,0 ),COLORFFBB11;
 STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,2.2,0 ),COLORFFCC22;
 STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1.65 ,0 ),COLORFFDD33;
 STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1.1 ,0 ),COLORFFEE44;
 STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,0.55 ,0 ),COLORFFFF55;
 IF(DIFF<0,DIFF,0),COLORRED,LINETHICK1;{好股票WWW.GOODGUPIAO.COM}
 IF(DIFF<0,0,DIFF),COLORYELLOW,LINETHICK1;
 IF(DIFF<DEA,DIFF,DEA),COLOR00FF00,LINETHICK1;
 IF(DIFF>DEA,DEA,DEA),COLORWHITE,LINETHICK1;
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
 STICKLINE(低位金叉,0,-4.5,2,0),COLORYELLOW;
 DRAWTEXT(低位金叉,-4,' 低位金叉'),COLORYELLOW;
 JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
 STICKLINE(二次金叉,0,-2.5,5,0),COLORFF00FF;
 DRAWICON(二次金叉,DEA*1.2,11) ;
 DRAWTEXT(二次金叉,-2,' 二次金叉'),COLORFF00FF;
 A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
 STICKLINE(底背离,0,2.5,3,0),COLOR00FF00;
 DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,LINETHICK2;
 DRAWTEXT(底背离,2,' 底背离'),COLOR00FF00;
 A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
 STICKLINE(顶背离,0,4.5,3,0),COLORFFFF00;
 DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORFFFF00,LINETHICK2;
 DRAWTEXT(顶背离,4,' 顶背离'),COLORFFFF00;
{ 原文链接:http://www.goodgupiao.com/gupiaogongshi/56704.html }